Formule SI dans Excel

Formule SI dans Excel

L’utilisation d’une formule SI dans Excel permet de résoudre bien des problèmes de calcul en introduisant une condition dans l’expression.

La fonction SI s’écrit ainsi avec des blocs de construction fictifs :

SI("une condition";"faire cette action";"sinon faire cette autre action")

Il y a 3 blocs de construction dans cette fonction : « une condition »;« faire cette action »;« sinon faire cette autre action ».

Notamment, l’exécution des 2 derniers blocs dépend directement de la condition.

Attention de ne pas mettre les guillemets. Ils servent uniquement à délimiter le rôle de chaque bloc de la fonction SI.

Blocs de construction

Le premier bloc de construction de la formule SI dans Excel est la condition.

Une condition peut être : G32 = « OUI » ou A5 >= 42

Il y a toujours 2 possibilités avec une condition. Par exemple, avec la condition A5 > =42 :

  • soit la valeur de A5 est supérieure ou égale à 42. Dans ce cas, la condition est vraie ou vérifiée.
  • soit la valeur de A5 est inférieure à 42. Dans ce cas, la condition est fausse ou non vérifiée.

Quand la condition est vraie, alors Excel va exécuter les instructions qui se trouvent dans le bloc « faire cette action »

Quand la condition est fausse, alors Excel va exécuter les instructions qui se trouvent dans le bloc « sinon faire cette autre action ».

Un bloc de construction peut lui-même être constitué de conditions SI, dont les blocs de construction peuvent aussi être constitués de conditions SI, et ainsi de suite. Dans ce cas, on parle de SI imbriqués.

Exemple concret d’une formule SI dans Excel

Afin d’être concret, vous trouverez ci-dessous un exemple de calcul de remises pour des clients.

Pour télécharger le classeur Excel : https://coudr.com/xlsremise

Ce tableau calcule un taux de remise pour les clients VIP. Le taux de remise dépend du montant des achats du mois précédents, ainsi que du montant cumulé des achats du mois.

Formule SI dans Excel
Formule SI dans Excel

Les 3 premiers clients n’ont pas fait d’achat le mois précédent. Pour cette raison, la colonne qui s’intitule Montant achats M-1, est vide.

La formule conditionnelle ci-dessous est utilisée pour déterminer le taux de remise.

=SI(ET(C8<=$C$3;D8<=$C$4);$C$5;SI(ET(C8<=$C$3;D8>$C$4);$D$5;SI(ET(C8>$C$3;D8<=$C$4);$E$5;SI(ET(C8>$C$3;D8>$C$4);$F$5))))

La même formule dans son contexte et en couleur 😉 :

Formule SI dans Excel
Formule SI dans Excel

Au total, il y a 4 fonctions SI car, si vous regardez le tableau avec les bordures, il y a 4 situations différentes, et donc 4 taux de remise différents.

Comprendre la formule SI dans Excel

Pour comprendre la formule SI dans Excel avec des fonctions SI imbriquées, il faut prendre le temps de reconnaître les blocs de construction.

Notamment, la fonction SI de l’exemple comprend bien 3 blocs de construction :

Condition : ET(C8<=$C$3;D8<=$C$4)

Faire cette action : =$C$5

Sinon faire cette autre action : =SI(ET(C8<=$C$3;D8>$C$4);$D$5;SI(ET(C8>$C$3;D8<=$C$4);$E$5;SI(ET(C8>$C$3;D8>$C$4);$F$5)))

La condition

Dans ce scénario, la condition de la formule SI dans Excel est :

ET(C8<=$C$3;D8<=$C$4) 

De plus, la condition utilise la fonction ET.

Cette fonction est vraie quand toutes les expressions à l’intérieur de la fonction ET sont vraies.

Notamment, dans l’exemple, il faut que les expressions C8<=$C$3 ET D8<=$C$4 soient vraies pour que ET(C8<=$C$3;D8<=$C$4) soit vraie.

L’expression C8<=$C$3 signifie que pour un client donné, le montant des achats du mois précédent est inférieur ou égal au seuil des 1 000 € du mois précédent.

L’expression D8<=$C$4 signifie que pour un client donné, le montant des achats du mois en cours est inférieur ou égal au seuil des 500 € du mois en cours.

Faire cette action

L’action quand la condition de la formule SI dans Excel est vraie :

=$C$5 

Excel exécute ce bloc d’instruction quand la condition est vraie.

Dans le cas présent, si la condition est vraie, Excel renvoie la valeur de la cellule $C$5, soit 2%.

Sinon faire cette autre action

L’action alternative quand la condition de la formule SI dans Excel est fausse :

=SI(ET(C8<=$C$3;D8>$C$4);$D$5;SI(ET(C8>$C$3;D8<=$C$4);$E$5;SI(ET(C8>$C$3;D8>$C$4);$F$5)))

Excel exécute ce bloc d’instruction si la condition précédente est fausse.

Par ailleurs, ce bloc contient une autre fonction SI imbriquée, mais le principe est le même.

Si vous prenez la peine de le décomposer, vous trouverez :

  • Condition : ET(C8<=$C$3;D8>$C$4)
  • Faire cette action : =$D$5
  • Sinon faire cette autre action : =SI(ET(C8>$C$3;D8<=$C$4);$E$5;SI(ET(C8>$C$3;D8>$C$4);$F$5))

Ce dernier bloc possède lui aussi une fonction SI imbriquée.

Télécharger le fichier avec la formule SI dans Excel

Vous vous pouvez télécharger le fichier Excel utilisé comme exemple : https://coudr.com/xlsremise

Pour aller plus loin

Consultez l’article qui explique comment Importer un tableau croisé dynamique Microsoft Excel dans Power BI.

Vous pouvez aussi prendre connaissance de l’article qui montre comment Exporter un classeur Microsoft Excel dans SharePoint, ou bien, au contraire, comment Exporter les données Power BI dans Microsoft Excel.

Un article plus technique montre comment il est possible d’Apprendre à insérer un calendrier dans un formulaire Microsoft Excel.


Commentaires

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *